1 %define name xscreensaver
4 Summary: X screen saver and locker
10 Group: Amusements/Graphics
11 URL: http://www.jwz.org/xscreensaver/
12 Source0: http://www.jwz.org/xscreensaver/xscreensaver-%{version}.tar.gz
13 Vendor: Jamie Zawinski <jwz@jwz.org>
14 Buildroot: %{_tmppath}/%{name}-root
17 Summary: A minimal installation of xscreensaver.
18 Summary(fr): Une installation minimale de xscreensaver.
19 Group: Amusements/Graphics
21 BuildRequires: gettext
22 BuildRequires: pam-devel
23 BuildRequires: gtk2-devel
24 BuildRequires: desktop-file-utils
26 #BuildRequires: xorg-x11-devel
27 #BuildRequires: libglade2-devel
28 # Red Hat 5, CentOS5, FC5, and up:
29 BuildRequires: xorg-x11-proto-devel
30 BuildRequires: libglade2-devel
32 #BuildRequires: libxorg-x11-devel
33 #BuildRequires: libglade2.0_0-devel
35 Requires: /etc/pam.d/system-auth
37 Requires: desktop-backgrounds-basic
38 Provides: xscreensaver
39 Provides: xscreensaver-base
40 Obsoletes: xscreensaver
43 Summary: An enhanced set of screensavers.
44 Summary(fr): Un jeu étendu d'économiseurs d'écran.
45 Group: Amusements/Graphics
46 Requires: xscreensaver-base
49 Summary: An enhanced set of screensavers that require OpenGL.
50 Summary(fr): Un jeu étendu d'économiseurs d'écran qui nécessitent OpenGL.
51 Group: Amusements/Graphics
52 Requires: xscreensaver-base
53 Obsoletes: xscreensaver-gl
56 A modular screen saver and locker for the X Window System.
57 More than 200 display modes are included in this package.
60 Un économiseur d'écran modulaire pour le système X Window.
61 Plus de 200 modes d'affichages sont inclus dans ce paquet.
64 A modular screen saver and locker for the X Window System.
65 This package contains the bare minimum needed to blank and
66 lock your screen. The graphical display modes are the
67 "xscreensaver-extras" and "xscreensaver-gl-extras" packages.
69 %description -l fr base
70 Un économiseur d'écran modulaire pour le système X Window.
71 Ce paquet contient le minimum vital pour éteindre et verouiller
72 votre écran. Les modes d'affichages graphiques sont inclus
73 dans les paquets "xscreensaver-extras" et "xscreensaver-gl-extras".
76 A modular screen saver and locker for the X Window System.
77 This package contains a variety of graphical screen savers for
78 your mind-numbing, ambition-eroding, time-wasting, hypnotized
81 %description -l fr extras
82 Un économiseur d'écran modulaire pour le système X Window.
83 Ce paquet contient une pléthore d'économiseurs d'écran graphiques
84 pour votre plaisir des yeux.
86 %description gl-extras
87 A modular screen saver and locker for the X Window System.
88 This package contains a variety of OpenGL-based (3D) screen
89 savers for your mind-numbing, ambition-eroding, time-wasting,
90 hypnotized viewing pleasure.
92 %description -l fr gl-extras
93 Un économiseur d'écran modulaire pour le système X Window.
94 Ce paquet contient une pléthore d'économiseurs d'écran basés sur OpenGL (3D)
95 pour votre plaisir des yeux.
100 if [ -x %{_datadir}/libtool/config.guess ]; then
101 # use system-wide copy
102 cp -p %{_datadir}/libtool/config.{sub,guess} .
106 archdir=`./config.guess`
110 export CFLAGS="${CFLAGS:-${RPM_OPT_FLAGS}}"
112 CONFIG_OPTS="--prefix=/usr --with-pam --without-shadow --without-kerberos"
114 # Red Hat doesn't like this:
115 CONFIG_OPTS="$CONFIG_OPTS --with-setuid-hacks"
118 # CONFIG_OPTS="$CONFIG_OPTS --with-login-manager"
121 %configure $CONFIG_OPTS
127 archdir=`./config.guess`
130 rm -rf ${RPM_BUILD_ROOT}
132 # We have to make sure these directories exist,
133 # or nothing will be installed into them.
135 mkdir -p $RPM_BUILD_ROOT%{_bindir} \
136 $RPM_BUILD_ROOT%{_datadir}/xscreensaver \
137 $RPM_BUILD_ROOT%{_libexecdir}/xscreensaver \
138 $RPM_BUILD_ROOT%{_mandir}/man1/xscreensaver \
139 $RPM_BUILD_ROOT/etc/pam.d
141 make install_prefix=$RPM_BUILD_ROOT install
143 desktop-file-install --vendor gnome --delete-original \
144 --dir $RPM_BUILD_ROOT%{_datadir}/applications \
145 $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
147 # This function prints a list of things that get installed.
148 # It does this by parsing the output of a dummy run of "make install".
151 make -s install_prefix=${RPM_BUILD_ROOT} INSTALL=true "$@" \
152 | sed -n -e 's@.* \(/[^ ]*\)$@\1@p' \
153 | sed -e "s@^${RPM_BUILD_ROOT}@@" \
154 -e "s@/[a-z][a-z]*/\.\./@/@" \
155 | sed -e 's@\(.*/man/.*\)@\1\*@' \
156 | sed -e 's@\(.*/app-defaults/\)@%config \1@' \
157 -e 's@\(.*/pam\.d/\)@%config(missingok) \1@' \
161 # Generate three lists of files for the three packages.
163 dd=%{_builddir}/%{name}-%{version}
164 ( cd hacks ; list_files install ) > $dd/extras.files
165 ( cd hacks/glx ; list_files install ) > $dd/gl-extras.files
166 ( cd driver ; list_files install ) > $dd/base.files
167 #( cd po ; list_files install ) >> $dd/base.files
170 cat %{name}.lang >> $dd/base.files
173 # Make sure all files are readable by all, and writable only by owner.
175 chmod -R a+r,u+w,og-w ${RPM_BUILD_ROOT}
178 rm -rf ${RPM_BUILD_ROOT}
181 # This part runs on the end user's system, when the RPM is installed.
183 # This will cause the screen to unlock, which annoys people. So, nevermind:
184 # people will just have to remember to re-launch it themselves, like they
185 # have to do with any other daemon they've upgraded.
187 #pids=`/sbin/pidof xscreensaver`
188 #if [ -n "$pids" ]; then
189 # echo "sending SIGHUP to running xscreensaver ($pids)..." >&2
193 %files -f base.files base
194 %defattr(-,root,root)
196 %files -f extras.files extras
197 %defattr(-,root,root)
199 %files -f gl-extras.files gl-extras
200 %defattr(-,root,root)
203 * Fri Nov 4 2005 Eric Lassauge <lassauge@users.sf.net>
204 - Updated french translations