]> git.hungrycats.org Git - linux/commit
SMB3 mounts fail with access denied to some servers
authorSteve French <smfrench@gmail.com>
Tue, 4 Dec 2012 22:56:37 +0000 (16:56 -0600)
committerGreg Kroah-Hartman <gregkh@linuxfoundation.org>
Fri, 11 Jan 2013 17:18:50 +0000 (09:18 -0800)
commite1593cb019046a8e29442a3376d8b30230e6a15d
treef8b189b2d1b4c240e48ab4ca08fa4ebcdd53aa5f
parent4fc832846b7e2afb0775be4521bcd801c60eba1f
SMB3 mounts fail with access denied to some servers

commit 52c0f4ad8ed462d81f1d37f56a74a71dc0c9bf0f upstream.

We were checking incorrectly if signatures were required to be sent,
so were always sending signatures after the initial session establishment.
For SMB3 mounts (vers=3.0) this was a problem because we were putting
SMB2 signatures in SMB3 requests which would cause access denied
on mount (the tree connection would fail).

This might also be worth considering for stable (for 3.7), as the
error message on mount (access denied) is confusing to users and
there is no workaround if the server is configured to only
support smb3.0. I am ok either way.

Signed-off-by: Steve French <smfrench@gmail.com>
Reviewed-by: Jeff Layton <jlayton@redhat.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
fs/cifs/smb2pdu.c